Actions











Petit probleme web

Écrit le 22 novembre 2006 @ 18:10 par Nick

Informatique - LinuxPour des raisons que j'ignore, j'ai souvent de la difficulté avec Firefox. Par exemple, lorsque j'ai plus de 3 tabs d'ouvert en même temps, mon ordinateur devient très lent au point ou je ne peux plus travailler, je ne peux même plus fermer Firefox et je dois tuer le process. Dans ce temps, le disque dur n'arrête pas de lire ou d'écrire et ça peut durer pendant des dizaines de minutes. Dans ce temps, le CPU est très smooth, à peine utilisé.

Aussi, lorsque j'écoute les têtes à claques, le CPU est au maximum et quelques fois ça lag parce que le CPU n'arrive pas à fournir.

Si vous avez des idées, n'hésiter pas à en faire part !!

En passant, c'est exactement le même problème avec Firefox 1.5.0.8 et avec Firefox 2.0.0.0.

Commentaire par Drizzt  Score: 2
Écrit le: 22/11/2006@18:50

En passant, c'est exactement le même problème avec Firefox 1.5.0.8 et avec Firefox 2.0.0.0.


La première question que j'étais pour te poser..

Peut-être un cas de recompilation Sourire sans les dents

Commentaire par Alexandre  Score: 2
Écrit le: 22/11/2006@22:49

Ce que je soupçonne, c'est du flash pour le problème de CPU. Il y a des problèmes majeurs avec la version 6.

Les têtes à claques, c'est en flash. Avoir quelques tabs d'ouverts risquent de faire tourner plusieurs animations flash. J'aimerais que tu vérifies si tu as du flash quand ça arrive.

Et vérifie la version du flash player que tu utilises. Pour ma part, j'utilise le beta2 de flash 9 et ça va bien. Beaucoup mieux qu'avec flash6, mais j'ai vu à au moins une reprise que le rendu était saccadé (mais le reste de mon ordi était OK), j'ai fait refresh et tout est rentré dans l'ordre.

Sinon, effectivement, peut-être devrais-tu penser à recompiler Firefox, ou mieux (à mon humble avis) utiliser Firefox directement du site de Mozilla. Dans le cas de Suse, la mise à jour automatique de firefox est désactivée, il faut toujours passer par l'utilitaire de mises à jour de Suse. Alors j'installe les versions de Mozilla et tout se fonctionne comme un charme. Ça pourrait t'aider avec ton problème de tab/HD IO.
Dernière modification le 22 novembre 2006 @ 22:50

Commentaire par Alexandre  Score: 2
Écrit le: 22/11/2006@22:57

Autre question: as-tu des effets 3D d'activés? Compiz, ça te dit quelque chose? J'ai lu que ça pouvait influencer sur les performances de tous les fureteurs... En particulier lors du scroll...

Commentaire par Nick  Score: 2
Écrit le: 23/11/2006@17:35

Je ne sais pas quel version de flash j'utilise. Par contre, je sais que j'ai copié la librairie de Flash 9 beta 2 dans /lib de Firefox 1.5 et dans Firefox 2 pour remplacer le 9 béta 1. Peut-être que deux versions de Flash roulent simultanément, la 9 et la 6. Dans ce cas, je ne sais pas trop quoi faire.

Pour ce qui est des RPM, Firefox 1.5 provient directement de Fedora en RPM. Par contre, le 2 a été compilé (maladroitement) par moi. Je ne sais pas non plus si ça pose problème avoir deux Firefox d'installé, dans deux répertoires différents.

Commentaire par Drizzt  Score: 2
Écrit le: 23/11/2006@20:12

En allant sur cette page, tu devrais pouvoir avoir la version de Flash que tu as d'active.

Il n'y a pas de problèmes à avoir 2 (ou 3, ou 4) versions différentes de FireFox en simultané, en supposant que ta compilation et l'installation ont été faites correctement.

Reviens-nous avec la version de Flash que tu as d'active, on verra ce que peut faire pour t'aider par la suite.

Commentaire par Nick  Score: 2
Écrit le: 23/11/2006@20:48

Simplement aller sur la page a ralenti considérablement mon ordi... je pense qu'on est proche du problème.

You have version
9,0,21,55 installed

Commentaire par Drizzt  Score: 2
Écrit le: 23/11/2006@22:33

C'est donc évident que ton problème est flash, mais tu as la dernière version.

Peux-tu confirmer la même chose avec FF1.5?

Commentaire par Alexandre  Score: 2
Écrit le: 27/11/2006@09:45

Il y a la version 9.0.22.78. Au fait, ton problème ne semble pas être isolé puisque d'autres personnes l'ont aussi rencontré.

Commentaire par Nick  Score: 2
Écrit le: 23/11/2006@17:35

J'ai oublié de dire que oui, je sais qu'il y a du flash dans les pages de démarrage, notamment celle de Télé-Québec.

Commentaire par Alexandre  Score: 2
Écrit le: 24/11/2006@12:02

Peux-tu me dire si tu as des effets 3D d'activés?

Commentaire par Nick  Score: 2
Écrit le: 29/11/2006@16:48

Je ne pense pas... du moins je n'ai rien fait pour que ce soit le cas...

Commentaire par Nick  Score: 2
Écrit le: 16/12/2006@14:07

Le problème a été trouvé, il s'agit d'un conflit entre BOINC et Firefox lorsqu'une des pages ouverte contient du flash. Comme solution possible, j'ai ajuster mes paramètres de BOINC pour diminuer la charge du CPU au maximum de 75%. De cette façon, il restera toujours un 25% de disponible pour les autres tâches. Si le problème se règle de cette façon, je vais progressivement réaugmenter le load du CPU sur BOINC jusqu'à un maximum éventuel de 95%.

Par contre, comme le client BOINC doit se connecter au serveur pour apprendre que les paramètres ont été changé, je dois terminer un work-unit entre chaque changement de pourcentage d'allocation. Me voici donc en période de tests pour un petit bout de temps. Je vous en redonne des nouvelles aussitt qu'il a du développement.


Toutes les entrées dans les journaux personnels
<< Nouvelles consoles | Retour au journal | EFU 2006 >>
Entrées journal du même auteur
<< Liste pour camping | EFU 2006 >>